Just another WordPress.com site

2) NIC (Network Interface Card) –> wire

– Ethernet –> 10 mbps

– Fast Ethernet –> 100 mbps

– Giga bit Ethernet –> 1000 mbps

– 10 Giga bit Ethernet –> 10000 mbps

3) Network Device

– Hub dan Switch –> menghubungkan antar komputer

– Router –> menghubungkan 2 jaringan yang berbeda.

– Bridge –> menghubungkan 2 jaringan yang sama.

 

perbedaan antara HUB dan SWITCH :

– bagaimana data/informasi yang dikirim kepada mereka diproses.
Ketika data masuk atau datang ke Hub, Hub akan mengambil data tersebut dan akan mentransmisikannya ke setiap komputer yang terhubung ke Jaringan.
Tetapi lain halnya dengan Switch, ia akan menerima data tersebut dan hanya akan mengirimkannya ke komputer yang berkepentingan menerima data tersebut.
Sehingga penggunaan Switch akan memotong penggunaan bandwith jaringan anda secara signifikan, terutama bila kita memiliki jaringan dengan banyak komputer yang tersambung dan semuanya mencoba untuk mengirim dan menerima data yang sama.

– jaringan yang terhubung dengan switch akan lebih aman dari kegiatan sniffer (pencurian data).

Komponen – Komponen Jaringan Komputer :

merupakan perangkat-perangkat yang digunakan untuk membangun sebuah jaringan.

1. PC (Personal Computer)

–> merupakan komponen utama dalam membangun sebuah jaringan.

2. NIC (Network Interface Card)

–> kartu atau papan elektronik yang ditanam pada setiap komputer yang terhubung ke jaringan.

 

Untuk menghubungkan dari komputer ke komputer kita menggunakan kabel cross.

 

Konsep dasar RG-45(8 pin) :

– untuk yang pakai putih selalu pada pin ganjil

– Pin 1 & pin 2 itu adalah yang sepasang

– Pin 3 & pin 6 itu adalah yang sepasang

– Pin 4 & pin 5 itu adalah yang sepasang

– Pin 7 & pin 8 itu adalah yang sepasang

Analisis adalah kajian yang dilaksanakan terhadap sebuah bahasa guna meneliti struktur bahasa tersebut secara mendalam.

Desain adalah proses untuk membuat dan menciptakan obyek baru.

Jadi, sebelum kita mendesain suatu jaringan, kita harus menganalisa nya terlebih dahulu.

Step 1: Consider how meeting the project goals will impact the existing network
a. As the network designer, look at the existing network topology and the services that it provides.
Consider how much of the network is affected or changed as a result of the project.
b. Record what areas of the existing network will have to change or will in some way be affected by
meeting the project goals.
Draft informal descriptive notes of these possible changes. Organize these notes under headings
such as:
  • Access Layer
  • Distribution Layer
  • Core Layer
  • Data Center
  • Network Services
  • WAN Access
c. Use word processing software to create a Project Scope document based on these notes.
 
Step 2: Refine and record the proposed changes to the existing network
a. Distinguish between possible upgrades to existing network resources, such as additional servers or
VLANs, and completely new additional resources, such as QoS and WAN links.
b. Record which areas and users will be affected by these changes.
c. Include these network changes in your Project Scope document.
Step 3: Define the areas of the existing network not covered by the project
It is important to note the parts of the existing network that are not within the areas covered by the project.
These out-of-scope areas are defined so that there is no misunderstanding between the NetworkingCompany and FilmCompany management.
In this case study, for example, providing IP telephony services may be a future consideration, but it is not
within the scope of this project.
Clearly state these out-of-scope areas in your Project Scope document.
 
Step 4: Compile and present the project scope document
FilmCompany has to agree with your assessment of the Project Scope before you proceed further with the design. An agreement ensures that there is a common understanding about what is included in the network upgrade project and what is not included.
a. Discuss your Project Scope with another student to ensure that the issues you present are clear.
b. Save your Project Scope document and retain it for the next stages of this network design case study.
 
Step 5: Reflection
It is important that a project have clearly defined boundaries so that all parties know what is included and
what is not. Consider the issues of ensuring that customer business and network needs are satisfied before the scope is broadened beyond what is feasible and required.
What strategies could be used to ensure that a project scope is developed that is clear and appropriate?
• Pastikan bahwa setiap layanan jaringan baru dan teknologi yang tidak termasuk dalam ruang lingkup semata-mata karena mereka dapat, pastikan mereka selaras dengan kebutuhan perusahaan dan tujuan.

• Apakah orang yang berbeda, baik dari perusahaan desain jaringan dan bisnis, meninjau lingkup proyek dan memberikan interpretasi mereka untuk memastikan bahwa itu berarti hal yang sama untuk semua orang.

Step 1: Record the company business goals and constraints that will influence the network design
As the network designer, you need to identify and prioritize the business goals of FilmCompany as defined in the Project Goals document. Develop your understanding of what these goals are from the FilmCompany case study information.
a. List these goals in order of priority.
b. Expand and consider the details of how these goals can be achieved using the network as a platform.
c. Note any constraints that these expanded goals may impose on the network design, such as retaining
the current number of IT and network support staff.
d. Use word processing software to create a Network Requirements document.
e. Clearly state the business goals and constraints in the document.
 
Step 2: Record the technical requirements that will influence the network design
a. Evaluate each of the business goals and determine the technical requirements to meet the goals.
List these technical requirements under the headings of:
  • Scalability
  • Availability and Performance
  • Security
  • Manageability
b. Initially, list all technologies that may be able to meet these technical requirements.
c. Include these requirements in your Network Requirements document.
Step 3: Record the user requirements that will influence the network design
a. Consider the types of users that will influence the network design. These users may be onsite, in the
office, in the video editing room, offsite (at the stadium), or mobile. Which types of users generate the heaviest amount of network traffic? Which types generate the lightest traffic?
How might different types of users be grouped for Access Layer purposes?
b. Include these requirements in your Network Requirements document.
 
Step 4: Record the application requirements that will influence the network design
a. Consider the type of applications that will influence the network design.
What applications are essentially device-based, with minimal network requirements?
Which applications are network-intensive?
Which applications and services are delivered onsite, in the offices, and which may need to be delivered offsite over the WAN or to mobile users?
b. Include these requirements in your Network Requirements document.
 
Step 5: Develop the network requirements
a. Refine the technical requirements of the network to match user and application requirements.
What compromises may have to be made to ensure that the project remains within the business
constraints?
b. Finalize the technical requirements of the network that will meet the project goals.
c. Discuss and review your Technical Requirements document with another student to ensure it addresses all the business, user, and application requirements within the Project Scope and does not unnecessarily address out-of-scope requirements. Modify the document as necessary.
d. Save and retain your Technical Requirements document for the next stage of this network design
case study.
 
Step 6: Reflection
Developing the technical requirements of a network that meets the project goals, while remaining within
scope, requires knowledge of the available and appropriate technologies and services.
Discuss strategies that will ensure that a network design team is up-to-date with networking technologies and their applications.
• Berlangganan ke jurnal teknis dan industri (baik hardcopy dan online)
• Menghadiri peluncuran dan demonstrasi produk
• Menghadiri seminar pelatihan dan kursus
• Menyusun dan melaksanakan rencana pengembangan diri professional

• Memelihara industri saat ini dan sertifikasi vendor

Step 1: Document and confirm existing network topology, addressing, and naming schemes
a. Examine the existing network topology diagram.
1)
2)
Record the current addressing scheme in a table.
Associate device names with addresses on the table.
b. Highlight any inconsistencies in the naming and addressing schemes.
For example:
  • Naming some devices by location and others by function
  • Inconsistent or confusing use of abbreviations
  • Some gateway addresses as the first address of a subnet, others as the last address
c. Use word processing software to create a Current Network document.
 
Step 2: Identify those parts of the existing network that currently meet the project technical requirements
a. Examine the network topology and specifications.
Record which current features meet the technical requirements of the proposed network upgrade.
  • Capacity (bandwidth, address ranges, VLANs)
  • Redundant links
  • Router and switch interfaces and ports
  • Router and switch feature sets, memory, and processing capability
  • WAN
  • Wireless
  • QoS
b. Include these strengths and capabilities in your Current Network document.
Potential strengths may include:
  • New wiring and adequate communications closets
  • Adequate space for a new data center
  • Servers and PCs are current models and will not need replacement
  • Some existing network switches and routers can be used in the new design
Step 3: Identify those parts of the existing network that can be scaled to meet the project technical requirements
a. Examine the network topology and specifications.
Record which current features do not meet the technical requirements of the proposed network
upgrade but can be scaled within the capacity of the network to do so.
  • Capacity (bandwidth, address ranges, VLANs)
  • Redundant links
  • Router and switch interfaces and ports
  • Router and switch feature sets, memory, and processing capability
  • WAN
  • Wireless
  • QoS
b. Include these scalable features and capabilities in your Current Network document.
 
Step 4: Identify those parts of the existing network that do not to meet the project technical requirements
a. Examine the network topology and specifications.
Record which current features do not meet the technical requirements of the proposed network
upgrade and what additional networking resources are required.
  • Capacity (bandwidth, address ranges, VLANs)
  • Redundant links
  • Router and switch interfaces and ports
  • Router and switch feature sets, memory, and processing capability
  • WAN
  • Wireless
  • QoS
b. Include these weaknesses and shortfalls in your Current Network document.
Possible weaknesses include:
  • Flat network design
  • Insufficient bandwidth at Distribution Layer, no true Core Layer
  • Servers poorly located
  • Multiple networks, difficult to maintain
  • Poor IP addressing structure
  • No dedicated bandwidth for WAN connectivity
  • Limited wireless implementation
  • Limited security implementations
 
Step 5: Obtain agreement and authorization from the company to continue with the network upgrade design
a. Finalize the Current Network document so that the strengths and shortfalls are clearly and precisely
presented.
b. Discuss and review your Current Network document with another student to ensure that it clearly
states which parts of the network meet the technical requirements of the upgrade project and which
parts do not. Amend the document as necessary to clarify any areas that could be misunderstood. At
this stage of the network design process, a meeting with the FilmCompany management would be
held to obtain their agreement and authorization to continue with the design of the upgrade.
c. Save and retain your Current Network document so that it can be incorporated with the previous
documents to complete this network design case study.
 
Step 6: Reflection
Consider the resources and information that will facilitate the task of analyzing a current network.
  • Having up-to-date documentation showing such information as addressing, device names, VLAN allocations, switch port assignments
  • Systematic and consistent host names, descriptions, and addressing schemes
  • Software tools that record data flows and device identification
  • Efficient and accurate fault and incidence reporting and clearance documentation to highlight and record problems
  • sistematis dan nama host yang konsisten, deskripsi, dan skema pengalamatan
  • Software tools yang merekam aliran data dan identifikasi perangkat
Step 1: Cable and configure the current network
a. Connect and configure the devices in accordance with the topology and configuration given. For this lab, a PC workstation can substitute for a Discovery Server.
b. Ping between Host 1 and Discovery Server to confirm network connectivity. Troubleshoot and establish connectivity if the pings fail.
 
Step 2: Configure NetFlow on the interfaces
NetFlow is configured to monitor data flows in or out of specific router interfaces. Ingress captures traffic that is being received by the interface. Egress captures traffic that is being transmitted by the interface. In this lab, the traffic will be monitored on both router interfaces and in both directions from within the console session.
a. From the global configuration mode, issue the following commands:
FC-CPE-1(config)#interface fastethernet 0/0
FC-CPE-1(config-if)#ip flow ?
Note the two options available:
egress Enable outbound NetFlow
ingress Enable inbound NetFlow
Which option captures traffic that is being received by the interface? ingress
Which option captures traffic that is being transmitted by the interface? egress
b. Complete the NetFlow configuration.
FC-CPE-1(config-if)#ip flow egress
FC-CPE-1(config-if)#ip flow ingress
FC-CPE-1(config-if)#interface fastethernet 0/1
FC-CPE-1(config-if)#ip flow ingress
FC-CPE-1(config-if)#ip flow egress
FC-CPE-1(config-if)#exit
FC-CPE-1(config)#end
Step 3: Verify the NetFlow configuration
a. From the privileged EXEC mode, issue the show running-configuration command.
For each FastEthernet interface, what statement from the running-configuration denotes that NetFlow is configured?
interface FastEthernet0/0:
ip flow ingress
ip flow egress
interface FastEthernet0/1:
ip flow ingress
ip flow egress
b. From the privileged EXEC mode, issue the command:
FC-CPE-1#show ip flow ?
Note the three options available:
export Display export
Statistics
interface Display flow
configuration on Interfaces
top-talkers Display top talkers
FC-CPE-1#show ip flow interface
FastEthernet0/0
ip flow ingress
ip flow egress
FastEthernet0/1
ip flow ingress
ip flow egress
Confirm that the output shown above is displayed. Troubleshoot your configuration if this output is not displayed.
Step 4: Create network data traffic
a. The captured data flow can be examined using the show ip cache flow command issued from the privileged EXEC mode.
FC-CPE-1#show ip cache flow
Issuing this command before any data traffic has flowed should produce output similar to the example shown here.
IP packet size distribution (0 total packets):
1-32 64 96 128 160 192 224 256 288 320 352 384 416 448 480
.000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
512 544 576 1024 1536 2048 2560 3072 3584 4096 4608
.000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 0 bytes
0 active, 0 inactive, 0 added
0 ager polls, 0 flow alloc failures
Active flows timeout in 30 minutes
Inactive flows timeout in 15 seconds
last clearing of statistics never
Protocol Total Flows Packets Bytes Packets Active(Sec)
Idle(Sec)
——– Flows /Sec /Flow /Pkt /Sec /Flow /Flow
SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP
Pkts
b. List the seven highlighted column headings and consider what use this information may be in characterizing the network.
Protocol
Total Flows
Flows per Second
Packets per Flow
Bytes per Packet
Packets per Second
Seconds of active flow
Seconds of no flow (idle)
c. To ensure that flow cache statistics are reset, from privileged EXEC mode issue the command:
FC-CPE-1# clear ip flow stats
d. Ping the Business Server from Host 1 to generate a data flow.
From the command line of Host 1, issue the command ping 172.17.1.1 -n 200
 
Step 5: View the data flows
a. At the conclusion of the data flow, the details of the flow can be viewed. From privileged EXEC mode,
issue the command:
FC-CPE-1#show ip cache flow
Output similar to that shown below will be displayed. Some values and details may be different in your lab.
IP packet size distribution (464 total packets):
1-32 64 96 128 160 192 224 256 288 320 352 384 416 448 480
.000 .900 .096 .000 .000 .000 .000 .002 .000 .000 .000 .000 .000 .000 .000
512 544 576 1024 1536 2048 2560 3072 3584 4096 4608
.000 .000 .000 .000 .000 .000 .000 .000 .000 .000 .000
IP Flow Switching Cache, 278544 bytes
5 active, 4091 inactive, 48 added
1168 ager polls, 0 flow alloc failures
Active flows timeout in 30 minutes
Inactive flows timeout in 15 seconds
IP Sub Flow Cache, 17416 bytes
0 active, 1024 inactive, 0 added, 0 added to flow
0 alloc failures, 0 force free
1 chunk, 1 chunk added
last clearing of statistics never
Protocol Total Flows Packets Bytes Packets Active(Sec)
Idle(Sec)
——– Flows /Sec /Flow /Pkt /Sec /Flow
/Flow
UDP-DNS 31 0.0 1 72 0.0 0.0
15.5
UDP-other 10 0.0 2 76 0.0 4.1
15.2
ICMP 2 0.0 200 60 0.3 198.9
15.3
Total: 43 0.0 10 61 0.3 10.2
15.5
SrcIf SrcIPaddress DstIf DstIPaddress Pr SrcP DstP
Pkts
< output omitted >
b. Examine your output and list details that indicate data flow.
Protocol
Total Flows
Flows per Second
Packets per Flow
Bytes per Packet
Packets per Second
Seconds of active flow
Seconds of no flow (idle)
 
Step 6: Stop the NetFlow capture
a. To deactivate NetFlow capture, issue the no ip flow command at the interface configuration prompt.
FC-CPE-1(config)#interface fastethernet 0/0
FC-CPE-1(config-if)#no ip flow ingress
FC-CPE-1(config-if)#no ip flow egress
FC-CPE-1(config)#interface fastethernet 0/1
FC-CPE-1(config-if)#no ip flow ingress
FC-CPE-1(config-if)#no ip flow egress
b. To verify that NetFlow is deactivated, issue the show ip flow interface command from the privileged EXEC mode.
FC-CPE-1#show ip flow interface
FC-CPE-1#
No output is displayed if NetFlow is off.
 
Step 7: Clean up
Erase the configurations and reload the routers and switches. Disconnect and store the cabling. For PC hosts that are normally connected to other networks (such as the school LAN or to the Internet), reconnect the appropriate cabling and restore the TCP/IP settings.
 
\Step 8: Reflection
Consider the possible range of data flow types across a network and how a tool like NetFlow could be implemented to assist in analyzing those flows.
List of data flow categories and types: Client to Client, Client to Server, Server to Client, and Server to Server Email, intranet web, database flows, document file flows Number of separate flows of each type, size (bytes) of each flow, time each flow is on the network Daftar kategori dan jenis aliran data: Client untuk Klien, Klien ke Server, Server untuk Client, dan Server ke Server
Email, web intranet, aliran database, file dokumen arus
Jumlah arus yang terpisah masing-masing jenis, ukuran (bytes) dari setiap aliran, waktu setiap aliran pada jaringan
Final Configurations
Router 1
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname FC-CPE-1
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
ip cef
!
!
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
ip flow ingress
ip flow egress
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.17.0.1 255.255.0.0
ip flow ingress
ip flow egress
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
!
line con 0
password cisco
login
line aux 0
line vty 0 4
password cisco
login
!
scheduler allocate 20000 1000
end

Tag Cloud